Question LED Dash Going Blank And Engine Stutter/Jolt While Riding

WarkworthHacker

New Member
Joined
Jul 28, 2021
Messages
3
Reaction score
2
Points
3
Location
UK
Visit site
Hi All, I am a newbie so sorry if this is in the wrong place.

My 2014 NC750S DCT has developed a fault where is you open the throttle even slightly the engine stutters, the bike jolts and the LCD dash goes blank. The engine recovers and the dash reappears but the bike is unrideable.

Any ideas?

By the way I am a mechanical imbecile so be gentle.
 

davidc83

Site Supporter
Joined
Jun 12, 2013
Messages
2,509
Reaction score
404
Points
83
Location
Southern Indiana/Central Florida-part time snow bi
Visit site
How old is the battery? The thing with DCT, needs really good batteries....If not a battery issue, disconnect the battery terminals, clean the terminal wires and posts on battery and reconnect.....Fuel injection vehicles need electricity from battery and sounds like loose, bad battery connection or battery about to give up the ghost...
 

WarkworthHacker

New Member
Joined
Jul 28, 2021
Messages
3
Reaction score
2
Points
3
Location
UK
Visit site
How old is the battery? The thing with DCT, needs really good batteries....If not a battery issue, disconnect the battery terminals, clean the terminal wires and posts on battery and reconnect.....Fuel injection vehicles need electricity from battery and sounds like loose, bad battery connection or battery about to give up the ghost...
Think that the battery is the original. It has let me down in the past so I wouldn’t be surprised if it is the cause.

Will act on your advice and update. Thanks for your advice.
 

potter0o

Site Supporter
Joined
Jun 19, 2015
Messages
1,315
Reaction score
226
Points
63
Location
Surrey, BC (Canada)
Visit site
I just replaced my battery on my 2013 a month ago. It would work fine for about two starts but with short breaks between starts it wouldn't go a third. I think I got my money's worth at 8 years. Would be nice if it is the battery as that is a relatively minor repair.

If you have a charger see if you can top up the charge in the battery. If that creates a positive result your probably on the right path. Your locally battery specialty shop may test if for free as another option.
 

WarkworthHacker

New Member
Joined
Jul 28, 2021
Messages
3
Reaction score
2
Points
3
Location
UK
Visit site
Quick update 12 hours on.
Putting the battery on an optimiser overnight appears to have all but eradicated the problem. I could make it happen every time before doing this but now only happened a couple of times at the start of a test run.
Looks like a new battery is called for.
Thanks again for the advice. Much appreciated.
 
Top