Search:

Type: Posts; User: Jerrdawg

Search: Search took 0.04 seconds.

  1. Replies
    18
    Views
    3,476

    Cogent!

    I had Cogent Dynamics build a set up for me. It works great. I'm a big guy and run with bags and a top case. Totally worth the money. I also passed on the remote adjuster.
  2. Replies
    248
    Views
    62,754

    Hello, After reading this thread a couple times I...

    Hello, After reading this thread a couple times I have a question. If our bike is rated for X about of weight (Rider and Gear) will getting a shock tuned for our weight make a difference?
    Would a...
  3. Replies
    108
    Views
    27,623

    Thanks to everyone for the suggestions. My issues...

    Thanks to everyone for the suggestions. My issues was related to the the Temperature Coolant Sensor. As soon as I replaced the sensor the issue disappeared. Hard to believe it failed so early in the...
  4. Replies
    108
    Views
    27,623

    Thanks 670cc for pointing me in the direction of...

    Thanks 670cc for pointing me in the direction of the temperature sensor (ECT Sensor). Just paging though the shop manual some of the symptoms are Hard start at low temperatures and cooling fan turns...
  5. Replies
    108
    Views
    27,623

    I drained the tank. Installed fresh gas with some...

    I drained the tank. Installed fresh gas with some FI cleaner last week. Still had a hard time starting but seemed to be getting better. This morning it totally didn't want to start at all. I finally...
  6. Replies
    108
    Views
    27,623

    Thanks Showkey. Yup that is the noise. I have...

    Thanks Showkey. Yup that is the noise.

    I have spark so I figure it has to bee fuel, right? The pump and solenoid seem to be working. I only had a gallon on gas in it, So I filled out the tank...
  7. Replies
    108
    Views
    27,623

    Thanks for the info. How about this. After I turn...

    Thanks for the info. How about this. After I turn the bike on, right after the fuel pump starts up, I hear a small zap or buzz like noise come from the front of the bike. Sounds like its down around...
  8. Replies
    108
    Views
    27,623

    Last May, I purchased a leftover 2014 with zero...

    Last May, I purchased a leftover 2014 with zero miles. Love the bike but the last few days I've had the same issues, and the very 1st video is exactly what my bike is doing. The bike normally starts...
  9. Replies
    29
    Views
    4,133

    This is the one I bought for my bike. It mounts...

    This is the one I bought for my bike. It mounts to the handlebar with a U-bolt. Then it has a movable arm that will allow you to position the phone craddle in various positions. I driven 50 miles...
  10. Replies
    27
    Views
    14,199

    Hello all. The link to the U.S. supplier to get...

    Hello all. The link to the U.S. supplier to get the connectors for the factory harness is off line. Anyone know another supplier? I'd like to keep my wiring simple and that looks like it could be...
  11. Replies
    1,175
    Views
    111,754

    I finally hooked up my Oxford Oximiser 900. I...

    I finally hooked up my Oxford Oximiser 900. I already had a lead off my battery for a USB port so the SAE connector was already installed. Hummm So I just pluged it in. Sounded way cooler in my head.
Results 1 to 11 of 11