Thanks Thanks:  0
Results 1 to 6 of 6

Thread: Weird lurch, hit a car

  1. #1
    Junior Member
    Bike: Nc700x dct
    Join Date
    Oct 2019
    Location
    Wisconsin
    Posts
    1

    Weird lurch, hit a car

    Has anyone with a DCT ever had a problem with sudden acceleration from a slow roll? It happened to me twice today, once when i was making a u turn and sent me into a car (ouch) and another as i was turning onto a street. Both were left turns.
    Ive been riding for 10 plus years. Previous bike was bmw gsa and I've got nearly a thousand miles on this bike since i got it in august. it also seemed to be running roughly after the first occurrence. Im wondering if when i had the shop try to put a riser on the bar if something got pinched or kinked. They had told me they ultimately couldn't do it because the cables were too short

  2. #2
    Junior Member
    Bike: nc700x
    Join Date
    Feb 2017
    Location
    GB
    Posts
    2
    Quote Originally Posted by jennyoung195 View Post
    Has anyone with a DCT ever had a problem with sudden acceleration from a slow roll? It happened to me twice today, once when i was making a u turn and sent me into a car (ouch) and another as i was turning onto a street. Both were left turns.
    Ive been riding for 10 plus years. Previous bike was bmw gsa and I've got nearly a thousand miles on this bike since i got it in august. it also seemed to be running roughly after the first occurrence. Im wondering if when i had the shop try to put a riser on the bar if something got pinched or kinked. They had told me they ultimately couldn't do it because the cables were too short
    If it's been to the mechanic and then you have problems.... look no further. Sounds like they've trapped the cable somewhere. Take it back to them.

    Sent from my SM-G935F using Tapatalk

  3. #3
    Super Moderator
    Bike: NC700x, ST1300, XR250L, CX500 Turbo, TRX350fwd, CT90, C70, TRX250, TRX 500, VFR1200x
    Join Date
    Dec 2012
    Location
    Wausau WI
    Posts
    1,836
    Sounds like a throttle cable free plays is set too tight or as mentioned riser and cable routing is wrong after the evaluation ?


    In neutral at idle ........so should be able to rotate the bars full sweep in both directions with no increase in engine speed.

  4. #4
    Senior Member melensdad's Avatar
    Bike: 2016 NC700x DCT + 2018 NC750x DCT
    Join Date
    Sep 2018
    Location
    Chicagoland (NW Indiana) USA
    Posts
    569
    Just a thought ... Do you have a "Crampbuster" or similar device added to you throttle grip?

    I had one on my bike for a while. My wife was riding my bike and had a similar situation and it turned out the crampbuster was inadvertently depressed in tight low speed left turn. She doesn't use one on her motorcycle so the cramp buster on my grip was a foreign thing to her. I eventually removed mine after it happened to me too. I'm not convinced that a cramp buster type device is particularly suitable for a DCT motorcycle.

    Anyway if you have any of the various designs of a cramp buster throttle aid that could the culprit.

  5. #5
    Senior Member Weird lurch, hit a car SilverRocket's Avatar
    Bike: 2016 NC700XDLG
    Join Date
    Jul 2017
    Location
    West Los Angeles, California
    Posts
    253
    I almost had a Crampbuster mishap when I tried to remove it when I came to a stoplight back in the city after a trip on the highway. I tried to get it off the throttle so twisted it and the bike jumped forward, something I'd never experienced before, as all my previous bikes were manual and would be in neutral when I would have tried such a thing.
    Good thing I had my right foot on the brake or I would have rear-ended a truck!
    Another reason why DCT owners need to always keep a toe over that rear brake.

  6. #6
    Senior Member Weird lurch, hit a car
    Weird lurch, hit a car
    Red Rider's Avatar
    Bike: 2016 NC700 DCT, latest in a long line
    Join Date
    Jan 2018
    Location
    Alabama
    Posts
    427
    And don’t try blipping the throttle under the overpass on day one of ownership.

    Just sayin....


    Iím supposed to respect my elders, but itís getting harder and harder for me to find one now ..

Similar Threads

  1. Weird Sound Under Heavy Acceleration
    By Speznar in forum Garage / Mechanical Help
    Replies: 10
    Last Post: 25th September 2019, 00:00
  2. Weird Tire Wear
    By ST13Fred in forum Garage / Mechanical Help
    Replies: 7
    Last Post: 18th June 2017, 07:48
  3. Weird Fuel Consumption.
    By SleepyC in forum NC700 General Discussion
    Replies: 18
    Last Post: 12th May 2017, 06:31
  4. Weird weather: Who has snow?
    By happy in forum The Bar
    Replies: 51
    Last Post: 5th May 2013, 15:27

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •