Results 1 to 10 of 10

Thread: CEL, Temp Light, Fan On, Low Idle

  1. #1
    Senior Member CEL, Temp Light, Fan On, Low Idle
    Bike: '14 DCT
    Join Date
    Mar 2015
    Location
    Loonyville, KY
    Posts
    203

    Question CEL, Temp Light, Fan On, Low Idle (Solved)

    Woke up to a broke bike this morning. I'm hoping someone can shed some light on this for me.

    When I turned the key on, the fan came on immediately. It was 40F this morning. When I hit the starter, the engine had to turn over for almost 10 seconds before it fired up and it took 3 attempts for it to happen. When it did, it idled at about 500 rpm and the CEL and temp light were on. When I gave any throttle input, the engine died. I ended up having to take the cage into work. I plan to try again when I get home. It should be ~60F by then so that can tell me whether or not it's temperature related. I only have ~30,000 miles on it.

    One other thing that is probably unrelated. The ABS light started flashing a few days ago. I've ridden it everyday since then with no engine issues. Likely separate problems

    Any thoughts?
    Last edited by Doc True; 23rd October 2019 at 08:17. Reason: Solved Issue
    "Roads are just a suggestion, like pants."

  2. #2
    Senior Member rippin209's Avatar
    Bike: 2013 NC700X
    Join Date
    Jan 2016
    Location
    US
    Posts
    1,543
    Sounds like you bike thinks it's really hot so I'd think temp sensor, I had to replace mine but I had the opposite problem, my fan wasn't coming on when it should have, but I never got an over heating light like you have, my temporary salutation (to get home) was to disconnect the temp sensor

    When you disconnect the temp sensor with the engine running the fan comes on immediately, now I'm not positive but it seems like the sensor completes a loop, when the water temp gets high enough it creates enough pressure to break the loop to and turn the fan on, I would guess even more pressure would open another (maybe) to turn on the dummy light (over heating light.

    But I'm just guessing

  3. #3
    Senior Member CEL, Temp Light, Fan On, Low Idle davidc83's Avatar
    Bike: Suzuki C50; 2009 klx250sf; 2013 Nc700
    Join Date
    Jun 2013
    Location
    Southern Indiana/Central Florida-part time snow bird..
    Posts
    1,985
    I wonder if a stuck thermostat (in the closed position) would cause this....or the water temperature sensor assy
    Last edited by davidc83; 17th October 2019 at 11:09.
    [SIGPIC][/SIGPIC]

  4. #4
    Senior Member CEL, Temp Light, Fan On, Low Idle
    Bike: '14 DCT
    Join Date
    Mar 2015
    Location
    Loonyville, KY
    Posts
    203
    Quote Originally Posted by davidc83 View Post
    I wonder if a stuck thermostat (in the closed position) would cause this....or the water temperature sensor assy
    I'm thinking maybe the sensor. I don't think a stuck thermostat would automatically turn the fan on
    "Roads are just a suggestion, like pants."

  5. #5
    Super Moderator
    Bike: NC700x, ST1300, XR250L, CX500 Turbo, TRX350fwd, CT90, C70, TRX250, TRX 500, VFR1200x
    Join Date
    Dec 2012
    Location
    Wausau WI
    Posts
    1,843
    First check:

    Battery voltage and connections.......simple and easy, a lot of weird or strange things happen when the battery is low or dying.

    Second: retrieve the code, kick stand down, turn the key on, count the CEL flashes (long and short flashes)

    Shop manual confirms if the ECT sensor ( engine coolant temp sensor) has an issue:
    Hard to start cold
    Cooling fan on

    Code 7-1 or 7-2 will flash.
    Last edited by showkey; 17th October 2019 at 15:01.

  6. #6
    Senior Member CEL, Temp Light, Fan On, Low Idle
    Bike: '14 DCT
    Join Date
    Mar 2015
    Location
    Loonyville, KY
    Posts
    203
    Everyone that guessed coolant temp sensor gets the prize. Turns out, someone cut the wires to the sensor for me. Once this is repaired, we can diagnose the other issues
    "Roads are just a suggestion, like pants."

  7. #7
    Senior Member CEL, Temp Light, Fan On, Low Idle davidc83's Avatar
    Bike: Suzuki C50; 2009 klx250sf; 2013 Nc700
    Join Date
    Jun 2013
    Location
    Southern Indiana/Central Florida-part time snow bird..
    Posts
    1,985
    Quote Originally Posted by Doc True View Post
    Everyone that guessed coolant temp sensor gets the prize. Turns out, someone cut the wires to the sensor for me. Once this is repaired, we can diagnose the other issues
    wow,,,who the heck did you upset over there??? Someone in your housing area dont like motorcycles?
    [SIGPIC][/SIGPIC]

  8. #8
    Senior Member CEL, Temp Light, Fan On, Low Idle
    Bike: '14 DCT
    Join Date
    Mar 2015
    Location
    Loonyville, KY
    Posts
    203
    Quote Originally Posted by davidc83 View Post
    wow,,,who the heck did you upset over there??? Someone in your housing area dont like motorcycles?
    I have no idea. The only time I ever interact with other residents is when they're walking they're dogs and the only purpose I have to do that is to pet the dogs
    "Roads are just a suggestion, like pants."

  9. #9
    Senior Member Rapturee's Avatar
    Bike: 2012 NC700x
    Join Date
    Feb 2018
    Location
    Post Falls IDAHO
    Posts
    1,422
    interesting.... :{)
    Fiat Justicia et Peret Mundus = Do the Right thing, Come what May!

  10. #10
    Senior Member Krampus's Avatar
    Bike: NC700/RSVRV2/900SS/VFR750F2
    Join Date
    Jan 2016
    Location
    United States
    Posts
    328
    Quote Originally Posted by Doc True View Post
    I have no idea. The only time I ever interact with other residents is when they're walking they're dogs and the only purpose I have to do that is to pet the dogs
    The more I get to know people, the more I like my dog. (Attributed to Mark Twain)

Similar Threads

  1. bags temp rating and ambient temp?
    By kalifornia in forum Touring and Traveling
    Replies: 15
    Last Post: 14th May 2019, 16:45
  2. temp gauge?
    By Junkie in forum NC700 Mods
    Replies: 2
    Last Post: 27th February 2019, 04:01
  3. Air Temp display?
    By Jackal in forum NC700 Mods
    Replies: 10
    Last Post: 13th September 2014, 14:43
  4. Coolant temp meter
    By duk2n in forum NC700 Mods
    Replies: 23
    Last Post: 7th May 2013, 21:43
  5. No temp gauge ??
    By Nortwestrider in forum NC700 General Discussion
    Replies: 2
    Last Post: 24th February 2013, 11:39

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •